Outils pour utilisateurs

Outils du site


fr:ogspy:installation

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
fr:ogspy:installation [2017/02/26 14:30]
darknoon
fr:ogspy:installation [2021/03/12 14:09] (Version actuelle)
Ligne 1: Ligne 1:
 ====== Installation OGSpy ====== ====== Installation OGSpy ======
  
 +Le tutoriel est aussi disponible sous forme de vidéo sur YouTube https://www.youtube.com/watch?v=pehma5j09Uc
 ===== Pré Requis ===== ===== Pré Requis =====
  
Ligne 13: Ligne 14:
 vous pouvez installer OGSpy sur votre site: vous pouvez installer OGSpy sur votre site:
  
-  * Un serveur web avec l'accès FTP et un accès à la base de données MySQL+  * Un serveur web supportant **PHP 7.2** avec l'accès FTP et un accès à la base de données MySQL
   * Un client FTP en ligne, [[http://filezilla-project.org/download.php?type=client|Filezilla]] pour Windows ou [[http://cyberduck.fr/|Cyberduck]] pour Mac.   * Un client FTP en ligne, [[http://filezilla-project.org/download.php?type=client|Filezilla]] pour Windows ou [[http://cyberduck.fr/|Cyberduck]] pour Mac.
 +  * Un certificat SSL pour assurer la sécurité des données entre le jeu et votre serveurs. ([[https://letsencrypt.org/]])
  
-OU+Des hébergements comme l'offre Perso d'OVH propose ce package : [[https://www.ovh.com/fr/hebergement-web/hebergement-perso.xml|Offre OVH à 3,5€/Mois]] 
 + 
 +OU pour les développeurs :
  
   * Un serveur local type Wamp qui inclus le serveur web/FTP et MySQL (http://www.wampserver.com/)   * Un serveur local type Wamp qui inclus le serveur web/FTP et MySQL (http://www.wampserver.com/)
  
-<note tip>Assurez vous que PHP 5.soit activé sur votre hébergement, cela vous évitera de nombreuses difficultées</note>+<note tip>Assurez vous que PHP 7.2, ou supérieur, soit activé sur votre hébergement, cela vous évitera de nombreuses difficultés</note>
  
 ===== Installation de OGSPY ===== ===== Installation de OGSPY =====
  
-  * Téléchargez OGSpy à ce lien : [[https://github.com/OGSteam/ogspy/releases/download/3.3.2/ogspy-3.3.2.zip|Lien de Téléchargement]]+  * Téléchargez OGSpy à ce lien (Choisissez la dernière version): [[https://github.com/OGSteam/ogspy/releases|Lien de Téléchargement]]
   * Décompressez le fichier compressé contenant les sources d'OGSpy.   * Décompressez le fichier compressé contenant les sources d'OGSpy.
   * Uploadez les fichiers sur le serveur FTP avec votre client FTP.   * Uploadez les fichiers sur le serveur FTP avec votre client FTP.
   * Rendez-vous sur l'url où vous avez uploadez vos fichiers. (Vous ne devez avoir aucune erreur, si ce n'est pas le cas regardez en fin de page.)   * Rendez-vous sur l'url où vous avez uploadez vos fichiers. (Vous ne devez avoir aucune erreur, si ce n'est pas le cas regardez en fin de page.)
  
- exemple: http://www.exemple.com/ogspy/+ exemple: https://www.exemple.com/ogspy/
  
 {{ :ogspy:tutorial.jpg?1000 |}} {{ :ogspy:tutorial.jpg?1000 |}}
Ligne 43: Ligne 47:
   * Cliquez sur "Démarrez l'installation complète".   * Cliquez sur "Démarrez l'installation complète".
  
-Une fois l'installation terminée, supprimez le dossier "install" et rendez-vous sur la page http://www.exemple.com/ogspy/index.php, allez dans la page administration et paramétrez OGSpy.+Une fois l'installation terminée, supprimez le dossier "install" et rendez-vous sur la page https://www.exemple.com/ogspy/index.php, allez dans la page administration et paramétrez OGSpy.
 ===== Installation des Mods ===== ===== Installation des Mods =====
  
Ligne 73: Ligne 77:
 Pour utiliser/configurer votre nouveau mod, il vous reste à cliquer sur le lien présent dans le menu ci dessus. Pour utiliser/configurer votre nouveau mod, il vous reste à cliquer sur le lien présent dans le menu ci dessus.
  
-<note tip>Pour la configuration d'Xtense : Rendez vous sur cette page : [[documentationxtense|Xtense Mod]]</note>+===== Configuration de Xtense ===== 
 + 
 +Pour récupérer les données sur le jeu vous aurez besoin de Xtense 
 + 
 +Xtense est composé d'un module côté OGSpy et d'une module à installer sur votre navigateur. 
 + 
 +Rendez vous sur cette page pour effectuer la configuration de l'ensemble : [[documentationxtense|Xtense Mod]]
  
  
Ligne 91: Ligne 101:
   * Lancer le lien   * Lancer le lien
  
-http://votrelienogspy.ooo/install/+https://votrelienogspy.ooo/install/
  
 Sur la page d'installation, sélectionnez mise à jour. Sur la page d'installation, sélectionnez mise à jour.
fr/ogspy/installation.1488115849.txt.gz · Dernière modification: 2021/03/12 14:09 (modification externe)